]> git.friedersdorff.com Git - max/gentoo-overlay.git/commitdiff
www-client/qutebrowser: Allow qutebrowser to depend on PyQtWebengine
authorMaximilian Friedersdorff <max@friedersdorff.com>
Mon, 18 Mar 2019 10:10:23 +0000 (10:10 +0000)
committerMaximilian Friedersdorff <max@friedersdorff.com>
Mon, 18 Mar 2019 10:10:23 +0000 (10:10 +0000)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Manifest-Sign-Key: BA1CE947376048A4B3C4D4E50B3B880CF5E7FCB3

www-client/qutebrowser/Manifest [new file with mode: 0644]
www-client/qutebrowser/metadata.xml [new file with mode: 0644]
www-client/qutebrowser/qutebrowser-1.6.0.ebuild [new file with mode: 0644]

diff --git a/www-client/qutebrowser/Manifest b/www-client/qutebrowser/Manifest
new file mode 100644 (file)
index 0000000..ab266da
--- /dev/null
@@ -0,0 +1,17 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST qutebrowser-1.6.0.tar.gz 3638739 BLAKE2B 8ca5995b9126fa7e017e3f2924c07c01b2d90540e0521d74cdba4ce8f2f83d1c7e8f0dc412ff41936c3a36c17d53060c331ed069d8088ac11b772979a48c7b0d SHA512 54b275f0d00ef48fa88a0bc83f31efd0d1fe708d7223adcf83c9d1a5db60de8e9c77033b8bf4b2b9a526d11ce39941d5d9da8afe9f49f3ed06e6f6f7ef124c20
+EBUILD qutebrowser-1.6.0.ebuild 2344 BLAKE2B ea7fb5e563519b8a880725f25863e8f8623b33b16609c7808d664b260d3b3e00f37f339eda6b0fa3b7dc31e101f659e0c577ca2c3829a4e9611c71aaee633441 SHA512 05bda56240a88614f7389f9cb76b9c0ec1c6406476db29a40c76298130b7319ee299611196621f2f43dc139f4d6ceaccf9692758ab897865faec62d303ee1478
+MISC metadata.xml 589 BLAKE2B 40485aca150508671b8b7fd65567c25abb73617b1f9d0d981c6ec9579b563904fefe5828e819276bb2c6e2c19883574334ffce0be7b047ad182bf3cdcadb70ea SHA512 e042cd2ad99080de919fce9f26a09cd6b1dd779cf2d2c8c26f8b214845635efc90e96e41acc025875ad7f8473ef750638ce4bf2f1ac3eeca6f7f762a44062ec0
+-----BEGIN PGP SIGNATURE-----
+
+iQEzBAEBCAAdFiEETdUSO77k6gzTbgmzTCaO99ou320FAlyPbo0ACgkQTCaO99ou
+321SUQgAgnPtzeI41V/t+NAMCVEyT7kaN0JJOHzhPL+Mwd627W1QAeleJ8iTHm/m
+dIy223YBvzwGTe7C26M71vFximaaS/MRwWjg52uFoml5ZyyM43M6s51m5Z5O2d1S
+/ZGWYMsiDM13e59QMMawdZG5ngKoq1vHFwS7lq4sUx3XsfBVMraKixYFDanRNWw2
+i8xIKNnlLD0DSL8HO6RWSfgXSJy6xqYA7XsFhHuAvAEocbBDuIYHWJHfiqTFCY7U
+BwoaD1GALQSRfc7gq0D9fh5c2nwFHefjoySE5TqGnQNxtANzwy2YBS/SmyODdn6q
+mSh5eTQO+SGI997VT8bnFIsyKU6mOA==
+=gGg3
+-----END PGP SIGNATURE-----
diff --git a/www-client/qutebrowser/metadata.xml b/www-client/qutebrowser/metadata.xml
new file mode 100644 (file)
index 0000000..3c4b943
--- /dev/null
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>radhermit@gentoo.org</email>
+               <name>Tim Harder</name>
+       </maintainer>
+       <maintainer type="person">
+               <email>jsbronder@gentoo.org</email>
+               <name>Justin Bronder</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">qutebrowser/qutebrowser</remote-id>
+       </upstream>
+       <use>
+               <flag name="scripts">Installs userscripts from the misc/userscripts
+                       directory to /usr/share/qutebrowser/userscripts.</flag>
+       </use>
+</pkgmetadata>
diff --git a/www-client/qutebrowser/qutebrowser-1.6.0.ebuild b/www-client/qutebrowser/qutebrowser-1.6.0.ebuild
new file mode 100644 (file)
index 0000000..71e3ff0
--- /dev/null
@@ -0,0 +1,83 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_5,3_6} )
+
+inherit distutils-r1 eutils gnome2-utils xdg-utils
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
+HOMEPAGE="https://www.qutebrowser.org/ https://github.com/qutebrowser/qutebrowser"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="scripts test"
+
+COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${COMMON_DEPEND}
+       app-text/asciidoc
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="${COMMON_DEPEND}
+       dev-python/attrs[${PYTHON_USEDEP}]
+       >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
+       >=dev-python/pygments-2.1.3[${PYTHON_USEDEP}]
+       >=dev-python/pypeg2-2.15.2[${PYTHON_USEDEP}]
+       >=dev-python/PyQt5-5.12_pre[${PYTHON_USEDEP},declarative,multimedia,gui,network,opengl,printsupport,sql,widgets]
+       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP},libyaml]
+"
+
+# Tests restricted as the deplist (misc/requirements/requirements-tests.txt)
+# isn't complete and X11 is required in order to start up qutebrowser.
+RESTRICT="test"
+
+python_compile_all() {
+       if [[ ${PV} == "9999" ]]; then
+               "${PYTHON}" scripts/asciidoc2html.py || die "Failed generating docs"
+       fi
+
+       a2x -f manpage doc/${PN}.1.asciidoc || die "Failed generating man page"
+}
+
+python_test() {
+       py.test tests || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       doman doc/${PN}.1
+       domenu misc/${PN}.desktop
+       doicon -s scalable icons/${PN}.svg
+
+       if use scripts; then
+               # Install only those userscripts that have an explicit license header
+               exeinto /usr/share/qutebrowser/userscripts/
+               doexe misc/userscripts/dmenu_qutebrowser
+               doexe misc/userscripts/openfeeds
+               doexe misc/userscripts/qute-keepass
+               doexe misc/userscripts/qute-pass
+               doexe misc/userscripts/rss
+               doexe misc/userscripts/tor_identity
+       fi
+
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+       optfeature "PDF display support" www-plugins/pdfjs
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+       gnome2_icon_cache_update
+}