]> git.friedersdorff.com Git - max/gentoo-overlay.git/commitdiff
media-sound/spotify: Attempt libressl spotify
authorMaximilian Friedersdorff <max@friedersdorff.com>
Wed, 24 Apr 2019 15:45:36 +0000 (16:45 +0100)
committerMaximilian Friedersdorff <max@friedersdorff.com>
Wed, 24 Apr 2019 15:45:36 +0000 (16:45 +0100)
Package-Manager: Portage-2.3.64, Repoman-2.3.12
Manifest-Sign-Key: BA1CE947376048A4B3C4D4E50B3B880CF5E7FCB3

media-sound/spotify/Manifest [new file with mode: 0644]
media-sound/spotify/metadata.xml [new file with mode: 0644]
media-sound/spotify/spotify-1.1.0.ebuild [new file with mode: 0644]

diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
new file mode 100644 (file)
index 0000000..272c2c8
--- /dev/null
@@ -0,0 +1,17 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST spotify-client_1.1.0.237.g378f6f25-11_amd64.deb 104760412 BLAKE2B d6cd695a41d80a47362b694e74b7d9d34a5c6480dbce189fa22d514126ab3022387871021a3d2a1301d9eb88c3b8f70755c1a5f880f9cc34c67c5faead7d84b8 SHA512 a1fcbf3463eea13a4ff38f4b40ae999c8e138abc8adf6988b4d764e597f166ef894baf449a6506a6b9b69ba3ed92c83dcb1a1eda23ab843c0441d2b71bbb0d51
+EBUILD spotify-1.1.0.ebuild 3491 BLAKE2B a279e1e8e85202f3255123e68081f91bbe2cbf2dbc459f2ce0518d558de44ba42db10b7010370f1127d0bb739f000c8ef948a7472183a36eeab44b5feea0e81e SHA512 2e15cb37461f19ee83bee244a4d24184791532a77c7f2be55445fd7cd358ca09143f91c9d3d01d6e080a579eba71f273214c60db1988d3e2ceb8282897ec560d
+MISC metadata.xml 459 BLAKE2B e06fc9b572f5d677194d78f04fc172cc13e7cd369bf5933f16e081a6bb05e3312b917d1de15fa6557777ba30f51907c43851d7a3c2bc4fb58de232634a4d4ed9 SHA512 e78bee1d25c70aeea5de11587a4017770b9a7df847f9371f612aead36cce440f070e91b37f802250ddf2aa1ec91fe87540cdbd85f6fd669ec4e1aaf01349c316
+-----BEGIN PGP SIGNATURE-----
+
+iQEzBAEBCAAdFiEETdUSO77k6gzTbgmzTCaO99ou320FAlzAhJ0ACgkQTCaO99ou
+322OrQf/ac2QFbXur0Y8eukwzq+G81LtGG2yObaRHuLuz4nP3ftLIv5lR/wDyAxP
+l6Nqn5gnJzkKYGCd5gk0T9Y1GcuT5PLWIRguWXup1u/VKC8kUtBZskmrcfRUb6Wy
+vTsajid9Zle45u2G7tGm0vMXqgtqMFwbboVwVFi52eptGOWhxaQKqm8lhWytd4GR
+6e0uJorDJp2MzDC5ZSX6aPSuPP0H8s2eXyIjy4F+Mut8nKAePySmoM5sxhPhl/VF
+I5mrG7hjFzMrXCVzvh/dXr0ToEmaXzgLp0w9/J8EUXtLko558ZCj1Y2Zz+OfbsU4
+scjqIF97pg7mXebvxkPje6mM0GKbKQ==
+=XYZm
+-----END PGP SIGNATURE-----
diff --git a/media-sound/spotify/metadata.xml b/media-sound/spotify/metadata.xml
new file mode 100644 (file)
index 0000000..1e06c14
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <use>
+    <flag name="pax_kernel">Triggers a paxmarking of the main Spotify binary</flag>
+    <flag name="systray">Pulls in dependencies needed for systray support on some desktop environments</flag>
+  </use>
+<maintainer type="person">
+<email>prometheanfire@gentoo.org</email>
+<name>Matthew Thode</name>
+</maintainer>
+</pkgmetadata>
diff --git a/media-sound/spotify/spotify-1.1.0.ebuild b/media-sound/spotify/spotify-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..1b2526f
--- /dev/null
@@ -0,0 +1,117 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils pax-utils unpacker xdg-utils
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
+BUILD_ID_AMD64="237.g378f6f25-11"
+#BUILD_ID_X86=""
+#SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb )
+#      x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_X86}_i386.deb )"
+SRC_URI="${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify libressl systray pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=">=dev-util/patchelf-0.9_p20180129"
+# zenity needed for filepicker
+RDEPEND="
+       libressl? ( dev-libs/libressl:0= )
+       !libressl? ( dev-libs/openssl:0= )
+       dev-libs/nss
+       gnome-base/gconf
+       gnome-extra/zenity
+       media-libs/alsa-lib
+       media-libs/harfbuzz
+       media-libs/fontconfig
+       media-libs/mesa
+       net-misc/curl[ssl]
+       net-print/cups[ssl]
+       x11-libs/gtk+:2
+       x11-libs/libXScrnSaver
+       x11-libs/libXtst
+       dev-python/pygobject:3
+       dev-python/dbus-python
+       libnotify? ( x11-libs/libnotify )
+       pulseaudio? ( media-sound/pulseaudio )
+       systray? ( gnome-extra/gnome-integration-spotify )"
+       #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+       # Fix desktop entry to launch spotify-dbus.py for systray integration
+       if use systray ; then
+               sed -i \
+                       -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+                       usr/share/spotify/spotify.desktop || die "sed failed"
+       fi
+       default
+
+       # Spotify links against libcurl-gnutls.so.4, which does not exist in Gentoo.
+       patchelf --replace-needed libcurl-gnutls.so.4 libcurl.so.4 usr/bin/spotify \
+               || die "failed to patch libcurl library dependency"
+}
+
+src_install() {
+       gunzip usr/share/doc/spotify-client/changelog.gz || die
+       dodoc usr/share/doc/spotify-client/changelog
+
+       SPOTIFY_PKG_HOME=usr/share/spotify
+       insinto /usr/share/pixmaps
+       doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+       # install in /opt/spotify
+       SPOTIFY_HOME=/opt/spotify/spotify-client
+       insinto ${SPOTIFY_HOME}
+       doins -r ${SPOTIFY_PKG_HOME}/*
+       fperms +x ${SPOTIFY_HOME}/spotify
+
+       dodir /usr/bin
+       cat <<-EOF >"${D}"/usr/bin/spotify || die
+               #! /bin/sh
+               exec ${SPOTIFY_HOME}/spotify "\$@"
+       EOF
+       fperms +x /usr/bin/spotify
+
+       local size
+       for size in 16 22 24 32 48 64 128 256 512; do
+               newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+                       "spotify-client.png"
+       done
+       domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+       if use pax_kernel; then
+               #create the headers, reset them to default, then paxmark -m them
+               pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+               pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+               pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+               eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+               eqawarn "${PN} under a PaX enabled kernel.  To do so, we must modify"
+               eqawarn "the ${PN} binary itself and this *may* lead to breakage!  If"
+               eqawarn "you suspect that ${PN} is being broken by this modification,"
+               eqawarn "please open a bug."
+       fi
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       xdg_mimeinfo_database_update
+       xdg_desktop_database_update
+
+       ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+       ewarn "To remove the cache:"
+       ewarn "rm -rf ~/.cache/spotify"
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       xdg_mimeinfo_database_update
+       xdg_desktop_database_update
+}