]> git.friedersdorff.com Git - max/slackbuilds.git/blob - office/todo.txt_cli/todo.txt-cli.SlackBuild
Move slackbuilds into categories
[max/slackbuilds.git] / office / todo.txt_cli / todo.txt-cli.SlackBuild
1 #!/bin/sh -e
2 # Maximilian Friedersdorff revision data 2016/10/02
3
4 # Set initial variables
5 CWD=$(pwd)
6 if [ "$TMP" = "" ]; then
7   TMP=/tmp
8 fi
9
10 VERSION=2.10
11 PKG_VERSION=2.10
12 BUILD=${BUILD:-1_maf}
13
14 APP=todo.txt-cli
15
16 PKG=$TMP/package-$APP
17
18 rm -rf $PKG
19 mkdir -p $TMP $PKG
20 rm -rf $TMP/$APP-$VERSION
21
22 cd $TMP || exit 1
23
24 tar -zxvf $CWD/$APP-$VERSION.tar.gz || exit 1
25 cd $APP-$VERSION || exit 1
26 chown -R root:root .
27 chmod -R u+w,go+r-w,a-s
28
29 mkdir -p $PKG/usr/bin
30 cp -a todo.sh $PKG/usr/bin/
31 mkdir -p $PKG/usr/share/bash-completion/completions
32 cp -a todo_completion $PKG/usr/share/bash-completion/completions/todo
33 mkdir -p $PKG/etc/todo
34 sed "s/^\(export[ \t]*TODO_DIR=\).*/\1~\/.todo/" todo.cfg > $PKG/etc/todo/config
35
36
37 mkdir -p $PKG/install
38 cat $CWD/slack-desc > $PKG/install/slack-desc
39
40 cd $PKG
41 /sbin/makepkg -l y -c n $TMP/$APP-$PKG_VERSION-$ARCH-$BUILD.tgz