]> git.friedersdorff.com Git - max/slackbuilds.git/blob - password-store/password-store.SlackBuild
Use git-master of password-store
[max/slackbuilds.git] / password-store / password-store.SlackBuild
1 #!/bin/sh
2
3 # Slackware build script for password-store
4
5 # Copyright 2013 Michael Ren <micron33@gmail.com>
6 # All rights reserved.
7 #
8 # Redistribution and use of this script, with or without modification, is
9 # permitted provided that the following conditions are met:
10 #
11 # 1. Redistributions of this script must retain the above copyright
12 #    notice, this list of conditions and the following disclaimer.
13 #
14 #  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
15 #  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
16 #  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
17 #  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
18 #  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
19 #  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
20 #  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
21 #  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
22 #  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
23 #  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
24
25 PRGNAM=password-store
26 VERSION=${VERSION:-git}
27 BUILD=${BUILD:-1}
28 TAG=${TAG:-_SBo}
29
30 ARCH=noarch
31
32 CWD=$(pwd)
33 TMP=${TMP:-/tmp/SBo}
34 PKG=$TMP/package-$PRGNAM
35 OUTPUT=${OUTPUT:-/tmp}
36
37 DOCS="COPYING INSTALL README"
38
39 set -e
40
41 rm -rf $PKG
42 mkdir -p $TMP $PKG $OUTPUT
43 cd $TMP
44 rm -rf $PRGNAM-$VERSION
45 tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
46 cd $PRGNAM-$VERSION
47 chown -R root:root .
48 find -L . \
49  \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
50   -o -perm 511 \) -exec chmod 755 {} \; -o \
51  \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
52   -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
53
54 make install FORCE_BASHCOMP=1 MANDIR=/usr/man DESTDIR=$PKG
55
56 # Adapted from the Makefile:
57 # Uncomment the two lines below to install the zsh completion file.
58 #mkdir -p "${PKG}/usr/share/zsh/site-functions"
59 #install -m 0644 -v contrib/pass.zsh-completion "${PKG}/usr/share/zsh/site-functions/_pass"
60
61 # Uncomment the two lines below to install the fish completion file.
62 #mkdir -p "${PKG}/usr/share/fish/completions"
63 #install -m 0644 -v contrib/pass.fish-completion "${PKG}/usr/share/fish/completions/pass.fish"
64
65 find $PKG/usr/man -type f -exec gzip -9 {} \;
66 for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
67
68 mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
69 cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
70 cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
71
72 mkdir -p $PKG/install
73 cat $CWD/slack-desc > $PKG/install/slack-desc
74
75 cd $PKG
76 /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}