]> git.friedersdorff.com Git - max/slackbuilds.git/blob - system/password-store/password-store.SlackBuild
Use most recent git version to build password-store
[max/slackbuilds.git] / system / password-store / password-store.SlackBuild
1 #!/bin/sh
2
3 # Slackware build script for password-store
4
5 # Copyright 2013 Michael Ren <micron33@gmail.com>
6 # Copyright 2017 Maximilian Friedersdorff <max@friedersdorff.com>
7 # All rights reserved.
8 #
9 # Redistribution and use of this script, with or without modification, is
10 # permitted provided that the following conditions are met:
11 #
12 # 1. Redistributions of this script must retain the above copyright
13 #    notice, this list of conditions and the following disclaimer.
14 #
15 #  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
16 #  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
17 #  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
18 #  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
19 #  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
20 #  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
21 #  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
22 #  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
23 #  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
24 #  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
25
26 PRGNAM=password-store
27 VERSION=${VERSION:-master}
28 BUILD=${BUILD:-1}
29 TAG=${TAG:-_max}
30
31 ARCH=noarch
32
33 CWD=$(pwd)
34 TMP=${TMP:-/tmp/SBo}
35 PKG=$TMP/package-$PRGNAM
36 OUTPUT=${OUTPUT:-/tmp}
37
38 DOCS="COPYING INSTALL README"
39
40 set -e
41
42 rm -rf $PKG
43 mkdir -p $TMP $PKG $OUTPUT
44 cd $TMP
45 rm -rf $PRGNAM-$VERSION
46 tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
47 cd $PRGNAM-$VERSION
48 chown -R root:root .
49 find -L . \
50  \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
51   -o -perm 511 \) -exec chmod 755 {} \; -o \
52  \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
53   -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
54
55 make install FORCE_BASHCOMP=1 MANDIR=/usr/man DESTDIR=$PKG
56
57 # Adapted from the Makefile:
58 # Uncomment the two lines below to install the zsh completion file.
59 #mkdir -p "${PKG}/usr/share/zsh/site-functions"
60 #install -m 0644 -v contrib/pass.zsh-completion "${PKG}/usr/share/zsh/site-functions/_pass"
61
62 # Uncomment the two lines below to install the fish completion file.
63 #mkdir -p "${PKG}/usr/share/fish/completions"
64 #install -m 0644 -v contrib/pass.fish-completion "${PKG}/usr/share/fish/completions/pass.fish"
65
66 find $PKG/usr/man -type f -exec gzip -9 {} \;
67 for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
68
69 mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
70 cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
71 cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
72
73 mkdir -p $PKG/install
74 cat $CWD/slack-desc > $PKG/install/slack-desc
75
76 cd $PKG
77 /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}