]> git.friedersdorff.com Git - max/slackbuilds.git/commitdiff
Add packages for qutebrowser and it's dependencies master
authorMaximilian Friedersdorff <max@friedersdorff.com>
Fri, 24 Nov 2017 23:56:39 +0000 (23:56 +0000)
committerMaximilian Friedersdorff <max@friedersdorff.com>
Fri, 24 Nov 2017 23:56:39 +0000 (23:56 +0000)
24 files changed:
libraries/python3-Jinja2/README [new file with mode: 0644]
libraries/python3-Jinja2/fix_doc_build.patch [new file with mode: 0644]
libraries/python3-Jinja2/python3-Jinja2.SlackBuild [new file with mode: 0755]
libraries/python3-Jinja2/python3-Jinja2.info [new file with mode: 0644]
libraries/python3-Jinja2/slack-desc [new file with mode: 0644]
libraries/python3-PyQt5/README [new file with mode: 0644]
libraries/python3-PyQt5/python3-PyQt5.SlackBuild [new file with mode: 0755]
libraries/python3-PyQt5/python3-PyQt5.info [new file with mode: 0644]
libraries/python3-PyQt5/slack-desc [new file with mode: 0644]
libraries/python3-pyPEG2/README [new file with mode: 0644]
libraries/python3-pyPEG2/python3-pyPEG2.SlackBuild [new file with mode: 0755]
libraries/python3-pyPEG2/python3-pyPEG2.info [new file with mode: 0644]
libraries/python3-pyPEG2/slack-desc [new file with mode: 0644]
network/qutebrowser/qutebrowser.SlackBuild [new file with mode: 0755]
network/qutebrowser/qutebrowser.info [new file with mode: 0644]
network/qutebrowser/slack-desc [new file with mode: 0644]
python/python3-attrs/README [new file with mode: 0644]
python/python3-attrs/python3-attrs.SlackBuild [new file with mode: 0755]
python/python3-attrs/python3-attrs.info [new file with mode: 0644]
python/python3-attrs/slack-desc [new file with mode: 0644]
python/python3-sip/README [new file with mode: 0644]
python/python3-sip/python3-sip.SlackBuild [new file with mode: 0755]
python/python3-sip/python3-sip.info [new file with mode: 0644]
python/python3-sip/slack-desc [new file with mode: 0644]

diff --git a/libraries/python3-Jinja2/README b/libraries/python3-Jinja2/README
new file mode 100644 (file)
index 0000000..d389ee4
--- /dev/null
@@ -0,0 +1,10 @@
+Jinja2 is a template engine written in pure Python.  It provides a
+Django inspired non-XML syntax but supports inline expressions and
+an optional sandboxed  environment.
+
+Circular dependencies warning: The DOCS=yes flag needs the optional
+dependency Sphinx, which needs Jinja2, which needs Sphinx because
+DOCS=yes ... So...  If you really need the docs, build Jinja2
+without the DOCS=yes flag, build Sphinx, then rebuild Jinja2 with
+DOCS=yes.  Incidentally, unless you are a developer, you don't
+normally need the DOCS=yes flag.
diff --git a/libraries/python3-Jinja2/fix_doc_build.patch b/libraries/python3-Jinja2/fix_doc_build.patch
new file mode 100644 (file)
index 0000000..4caa78a
--- /dev/null
@@ -0,0 +1,11 @@
+--- docs/jinjaext.py   2014-01-10 12:14:43.000000000 +0200
++++ docs/jinjaext.py.patched   2014-01-24 23:31:50.511110780 +0200
+@@ -23,7 +23,7 @@
+ from pygments.token import Keyword, Name, Comment, String, Error, \
+      Number, Operator, Generic
+ from jinja2 import Environment, FileSystemLoader
+-from jinja2.utils import next
++from jinja2._compat import next
+ def parse_rst(state, content_offset, doc):
diff --git a/libraries/python3-Jinja2/python3-Jinja2.SlackBuild b/libraries/python3-Jinja2/python3-Jinja2.SlackBuild
new file mode 100755 (executable)
index 0000000..394f5cd
--- /dev/null
@@ -0,0 +1,81 @@
+#!/bin/sh
+
+# Slackware build script for Jinja2
+
+# Copyright 2014 Mikko Värri, Finland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+#    notice, this list of conditions and the following disclaimer.
+#
+#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
+#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-Jinja2
+PRGNAM_SRC=Jinja2
+VERSION=${VERSION:-2.7.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_maf}
+
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i486 ;;
+    arm*) ARCH=arm ;;
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS=${DOCS:-no}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM_SRC-$VERSION.tar.gz
+cd $PRGNAM_SRC-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+if [ "$DOCS" = "yes" ]; then
+  # Patch from: https://github.com/mitsuhiko/jinja2/pull/259
+  patch -p0 <$CWD/fix_doc_build.patch
+  make -C docs html
+fi
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGES LICENSE ext examples $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/_build/html $PKG/usr/doc/$PRGNAM-$VERSION || cp -a docs $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python3-Jinja2/python3-Jinja2.info b/libraries/python3-Jinja2/python3-Jinja2.info
new file mode 100644 (file)
index 0000000..2be0ba9
--- /dev/null
@@ -0,0 +1,10 @@
+PRGNAM="python3-Jinja2"
+VERSION="2.7.3"
+HOMEPAGE="https://pypi.python.org/pypi/Jinja2"
+DOWNLOAD="https://pypi.python.org/packages/source/J/Jinja2/Jinja2-2.7.3.tar.gz"
+MD5SUM="b9dffd2f3b43d673802fe857c8445b1a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="MarkupSafe"
+MAINTAINER="Maximilian Friedersdorff"
+EMAIL="max@friedersdorff.com"
diff --git a/libraries/python3-Jinja2/slack-desc b/libraries/python3-Jinja2/slack-desc
new file mode 100644 (file)
index 0000000..11066a1
--- /dev/null
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+      |-----handy-ruler------------------------------------------------------|
+Jinja2: Jinja2 (Template engine for Python)
+Jinja2:
+Jinja2: Jinja2 is a template engine written in pure Python.  It provides a
+Jinja2: Django inspired non-XML syntax but supports inline expressions and
+Jinja2: an optional sandboxed  environment.
+Jinja2:
+Jinja2:
+Jinja2:
+Jinja2:
+Jinja2:
+Jinja2:
diff --git a/libraries/python3-PyQt5/README b/libraries/python3-PyQt5/README
new file mode 100644 (file)
index 0000000..23ab8cb
--- /dev/null
@@ -0,0 +1,2 @@
+PyQt5 is a set of Python bindings for Trolltech's Qt5 application
+framework and runs on all platforms supported by Qt5.
diff --git a/libraries/python3-PyQt5/python3-PyQt5.SlackBuild b/libraries/python3-PyQt5/python3-PyQt5.SlackBuild
new file mode 100755 (executable)
index 0000000..884a56f
--- /dev/null
@@ -0,0 +1,113 @@
+#!/bin/sh
+
+# Slackware build script for "python3-PyQt5".
+
+# Copyright 2008  Aleksandar Samardzic <asamardzic@gmail.com>
+# Copyright 2008, 2009, 2010, 2011, 2015  Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2015 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by Robby Workman <rworkman@slackware.com>
+# Modified by Eric Hameleers <alien@slackware.com>
+# Adapted by Marcel Saegebarth <marc@mos6581.de>
+
+PRGNAM=python3-PyQt5
+SRCNAM=PyQt5
+VERSION=${VERSION:-5.9.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i486 ;;
+    arm*) ARCH=arm ;;
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+else
+  SLKCFLAGS="-O2"
+  LIBDIRSUFFIX=""
+fi
+
+PYTHONVER=$(python3 -V 2>&1 | cut -f 2 -d' ' | cut -f 1-2 -d.)
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf ${SRCNAM}_gpl-$VERSION
+tar xvf $CWD/${SRCNAM}_gpl-$VERSION.tar.gz
+cd ${SRCNAM}_gpl-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+  -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# This is needed or an include from dbus is missed (thanks, Archlinux)
+sed -i '/target_config.dbus_inc_dirs = \[\]/d' configure.py
+
+export QTDIR=/usr/lib${LIBDIRSUFFIX}/qt5
+export QT5DIR=/usr/lib${LIBDIRSUFFIX}/qt5
+
+export CFLAGS="$SLKCFLAGS"
+export CXXFLAGS="$SLKCFLAGS"
+
+python3 configure.py \
+  --confirm-license \
+  --verbose \
+  -q /usr/bin/qmake-qt5 \
+  --sip=/usr/bin/python3-sip \
+  --sip-incdir=/usr/include/python$PYTHONVER
+
+make
+make install DESTDIR=$PKG INSTALL_ROOT=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog LICENSE NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python3-PyQt5/python3-PyQt5.info b/libraries/python3-PyQt5/python3-PyQt5.info
new file mode 100644 (file)
index 0000000..0e6e34b
--- /dev/null
@@ -0,0 +1,10 @@
+PRGNAM="python3-PyQt5"
+VERSION="5.9.2"
+HOMEPAGE="https://riverbankcomputing.com/software/pyqt/intro/"
+DOWNLOAD="https://downloads.sourceforge.net/project/pyqt/PyQt5/PyQt-5.9.2/PyQt5_gpl-5.9.2.tar.gz"
+MD5SUM="33d6d2ab8183da17ac18b8132a4b278e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-sip qt5-webkit"
+MAINTAINER="Maximilian Friedersdorff"
+EMAIL="max@friedersdorff.com"
diff --git a/libraries/python3-PyQt5/slack-desc b/libraries/python3-PyQt5/slack-desc
new file mode 100644 (file)
index 0000000..0c57255
--- /dev/null
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+             |-----handy-ruler------------------------------------------------------|
+python3-PyQt5: python3-PyQt5 (Python bindings for Qt)
+python3-PyQt5:
+python3-PyQt5: PyQt5 is a set of Python bindings for Trolltech's Qt5 application
+python3-PyQt5: framework and runs on all platforms supported by Qt5.
+python3-PyQt5:
+python3-PyQt5: Homepage: https://riverbankcomputing.com/software/pyqt/intro/
+python3-PyQt5:
+python3-PyQt5:
+python3-PyQt5:
+python3-PyQt5:
+python3-PyQt5:
diff --git a/libraries/python3-pyPEG2/README b/libraries/python3-pyPEG2/README
new file mode 100644 (file)
index 0000000..47811fd
--- /dev/null
@@ -0,0 +1,6 @@
+pyPEG2 (plain and simple intrinsic parser interpreter for Python)
+
+pyPEG2  is  a plain and simple intrinsic parser interpreter framework
+for  Python version  2.7 and  3.x.  It is based on Parsing Expression
+Grammar (PEG).  With  pyPEG  you  can  parse  many  formal  languages
+in a very easy way.
diff --git a/libraries/python3-pyPEG2/python3-pyPEG2.SlackBuild b/libraries/python3-pyPEG2/python3-pyPEG2.SlackBuild
new file mode 100755 (executable)
index 0000000..71df43f
--- /dev/null
@@ -0,0 +1,86 @@
+#!/bin/sh
+#
+# Slackware build script for pyPEG2.
+#
+# Copyright 2015-2017  Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+#    notice, this list of conditions and the following disclaimer.
+#
+#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
+#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-pyPEG2
+PRGNAM_SRC=pyPEG2
+VERSION=${VERSION:-2.15.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_maf}
+
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i586 ;;
+    arm*) ARCH=arm ;;
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+else
+  SLKCFLAGS="-O2"
+  LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM_SRC.tar.gz
+cd $PRGNAM_SRC-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+  -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.txt LICENSE.txt PKG-INFO README.txt TODO.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python3-pyPEG2/python3-pyPEG2.info b/libraries/python3-pyPEG2/python3-pyPEG2.info
new file mode 100644 (file)
index 0000000..2b7d0b6
--- /dev/null
@@ -0,0 +1,10 @@
+PRGNAM="python3-pyPEG2"
+VERSION="2.15.2"
+HOMEPAGE="https://fdik.org/pyPEG/"
+DOWNLOAD="https://fdik.org/pyPEG2/pyPEG2.tar.gz"
+MD5SUM="2ff44bc843c61ccd3951ef66a9e4a2b0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="lxml"
+MAINTAINER="Maximilian Friedersdorff"
+EMAIL="max@friedersdorff.com"
diff --git a/libraries/python3-pyPEG2/slack-desc b/libraries/python3-pyPEG2/slack-desc
new file mode 100644 (file)
index 0000000..3215957
--- /dev/null
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+      |-----handy-ruler------------------------------------------------------|
+pyPEG2: pyPEG2 (plain and simple intrinsic parser interpreter for Python)
+pyPEG2:
+pyPEG2: pyPEG2  is  a plain and simple intrinsic parser interpreter framework
+pyPEG2: for Python version 2.7 and 3.x.
+pyPEG2:
+pyPEG2: Home page: https://fdik.org/pyPEG/
+pyPEG2:
+pyPEG2:
+pyPEG2:
+pyPEG2:
+pyPEG2:
diff --git a/network/qutebrowser/qutebrowser.SlackBuild b/network/qutebrowser/qutebrowser.SlackBuild
new file mode 100755 (executable)
index 0000000..5b96f96
--- /dev/null
@@ -0,0 +1,104 @@
+#!/bin/sh -e
+
+# Slackware build script for qutebrowser
+
+# Copyright 2017 Maximilian Friederdorff
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+# 
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
+
+# set up some variables for the build process
+CWD=$(pwd)
+if [ "$TMP" = "" ]; then
+  TMP=/tmp
+fi
+
+APP="qutebrowser"
+VERSION=${VERSION:-1.0.3}
+PKG_VERSION=$VERSION
+
+# Detect the architecture
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) export ARCH=i586 ;;
+    arm*) export ARCH=arm ;;
+    # Unless $ARCH is already set, use uname -m for all other archs:
+    *) export ARCH=$( uname -m ) ;;
+  esac
+fi
+
+if [ "$ARCH" = "i486" ]; then
+  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+fi
+
+NUMJOBS=${NUMJOBS:-" -j4 "}
+
+BUILD=${BUILD:-1_maf}
+PKG=$TMP/package-$APP
+
+# Clean build location in case of previous build attempts
+rm -rf $PKG
+mkdir -p $TMP $PKG
+rm -rf $TMP/$APP-$VERSION
+
+cd $TMP || exit 1
+
+# Extract sources
+tar -zxvf $CWD/${APP}-${VERSION}-1.tar.gz || exit 1
+cd $APP-$VERSION || exit 1
+
+# Ensure ownership and permissions are consistant 
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Build and install
+python3 setup.py build
+python3 setup.py install --root="$PKG/" --optimize=1
+install -dm755 $PKG/usr/share/qutebrowser/userscripts
+find misc/userscripts -type f -exec install -m755 {} $PKG/usr/share/qutebrowser/userscripts \;
+
+# Install documentation
+a2x -f manpage doc/qutebrowser.1.asciidoc
+install -Dm644 doc/qutebrowser.1 $PKG/usr/man/man1/qutebrowser.1
+
+mkdir -p $PKG/usr/doc/$APP-$VERSION
+cp -a README.asciidoc LICENSE MANIFEST.in doc/ $PKG/usr/doc/$APP-$VERSION 
+find $PKG/usr/doc/$APP-$VERSION -type f -exec chmod 644 {} \;
+cat $CWD/$APP.SlackBuild > $PKG/usr/doc/$APP-$VERSION/$APP.SlackBuild
+
+# Install slack-desc file
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# Strip some libraries and binaries
+
+# Compress man pages if they exist
+if [ -d $PKG/usr/man ]; then
+  ( cd $PKG/usr/man
+  find . -type f -exec gzip -9 {} \;
+  for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
+  ) 
+fi
+
+# Compress info pages if they exist (and remove the dir file)
+if [ -d $PKG/usr/info ]; then
+  gzip -9 $PKG/usr/info/*.info
+  rm -f $PKG/usr/info/dir
+fi
+
+# Make the package
+cd $PKG
+/sbin/makepkg -l y -c n $TMP/$APP-$PKG_VERSION-$ARCH-$BUILD.tgz
diff --git a/network/qutebrowser/qutebrowser.info b/network/qutebrowser/qutebrowser.info
new file mode 100644 (file)
index 0000000..21d2976
--- /dev/null
@@ -0,0 +1,8 @@
+PRGNAM="qutebrowser"
+VERSION="1.0.3"
+HOMEPAGE="https://qutebrowser.org/"
+DOWNLOAD="https://github.com/qutebrowser/qutebrowser/releases/download/v1.0.3/qutebrowser-1.0.3-1.tar.gz"
+MD5SUM="896a7a6e13bd78ac082b9deae9562acd"
+REQUIRES="qt5 python3-PyQT5 python3-pyPEG2 python3-Jinja2 python3-Pygments python3-PyYAML python3-attrs"
+MAINTAINER="Maximilian Friedersdorff"
+EMAIL="max@friedersdorff.com"
diff --git a/network/qutebrowser/slack-desc b/network/qutebrowser/slack-desc
new file mode 100644 (file)
index 0000000..29e4694
--- /dev/null
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.  Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in.  You must make
+# exactly 11 lines for the formatting to be correct.  It's also customary to
+# leave one space after the ':'.
+
+           |-----handy-ruler------------------------------------------------------|
+qutebrowser: qutebrowser 
+qutebrowser:
+qutebrowser: qutebrowser is a keyboard-focused browser with a minimal GUI. It's 
+qutebrowser: based on Python and PyQT5 and free software, licensed under the GPL.
+qutebrowser:
+qutebrowser: It was inspired by other browsers/addons like dwb and
+qutebrowser: Vimperator/Pentadactyl
+qutebrowser:
+qutebrowser:
+qutebrowser: Homepage: https://qutebrowser.org/ 
+qutebrowser:
diff --git a/python/python3-attrs/README b/python/python3-attrs/README
new file mode 100644 (file)
index 0000000..8f3e9d7
--- /dev/null
@@ -0,0 +1,3 @@
+attrs is an MIT-licensed Python package with class decorators that
+ease the chores of implementing the most common attribute-related
+object protocols.
diff --git a/python/python3-attrs/python3-attrs.SlackBuild b/python/python3-attrs/python3-attrs.SlackBuild
new file mode 100755 (executable)
index 0000000..13f593f
--- /dev/null
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for attrs
+
+# Copyright 2016-2017 Markus Reichelt, Aachen, DE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+#    notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-attrs
+PRGNAM_SRC=attrs
+VERSION=${VERSION:-16.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_maf}
+
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i586 ;;
+    arm*) ARCH=arm ;;
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+else
+  SLKCFLAGS="-O2"
+  LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM_SRC-$VERSION.tar.gz
+cd $PRGNAM_SRC-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+  -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst docs/ LICENSE PKG-INFO  $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-attrs/python3-attrs.info b/python/python3-attrs/python3-attrs.info
new file mode 100644 (file)
index 0000000..cfd2ef3
--- /dev/null
@@ -0,0 +1,10 @@
+PRGNAM="python3-attrs"
+VERSION="16.3.0"
+HOMEPAGE="https://pypi.python.org/pypi/attrs"
+DOWNLOAD="https://pypi.python.org/packages/01/b0/3ac73bf6df716a38568a16f6a9cbc46cc9e8ed6fe30c8768260030db55d4/attrs-16.3.0.tar.gz"
+MD5SUM="4ec003c49360853cf935113d1ae56151"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Maximilian Friedersdorff"
+EMAIL="max@friedersdorff.com"
diff --git a/python/python3-attrs/slack-desc b/python/python3-attrs/slack-desc
new file mode 100644 (file)
index 0000000..c712e5e
--- /dev/null
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+     |-----handy-ruler------------------------------------------------------|
+attrs: attrs (attributes without boilerplate)
+attrs:
+attrs: attrs is an MIT-licensed Python package with class decorators that
+attrs: ease the chores of implementing the most common attribute-related
+attrs: object protocols.
+attrs:
+attrs: Homepage: https://pypi.python.org/pypi/attrs
+attrs:
+attrs:
+attrs:
+attrs:
diff --git a/python/python3-sip/README b/python/python3-sip/README
new file mode 100644 (file)
index 0000000..73272f0
--- /dev/null
@@ -0,0 +1,4 @@
+SIP is a tool that makes it very easy to create Python bindings for
+C and C++ libraries.  It was originally developed to create PyQt,
+the Python bindings for the Qt toolkit, but can be used to create
+bindings for any C or C++ library.
diff --git a/python/python3-sip/python3-sip.SlackBuild b/python/python3-sip/python3-sip.SlackBuild
new file mode 100755 (executable)
index 0000000..d500041
--- /dev/null
@@ -0,0 +1,108 @@
+#!/bin/sh
+
+# Copyright 2008  Aleksandar Samardzic <asamardzic@gmail.com>
+# Copyright 2008, 2009, 2010, 2011  Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2016 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by Robby Workman <rworkman@slackware.com>
+# Modified by Eric Hameleers <alien@slackware.com>
+# Adapted by Marcel Saegebarth <marc@mos6581.de>
+
+PRGNAM=python3-sip
+SRCNAM=sip
+VERSION=${VERSION:-4.19.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+  case "$( uname -m )" in
+    i?86) ARCH=i486 ;;
+    arm*) ARCH=arm ;;
+       *) ARCH=$( uname -m ) ;;
+  esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+  LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+  SLKCFLAGS="-O2 -fPIC"
+  LIBDIRSUFFIX="64"
+else
+  SLKCFLAGS="-O2"
+  LIBDIRSUFFIX=""
+fi
+
+PYTHONVER=$(python3 -V 2>&1 | cut -f 2 -d' ' | cut -f 1-2 -d.)
+PYTHONLIB=/usr/lib$LIBDIRSUFFIX/python$PYTHONVER/site-packages
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+  -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 configure.py \
+  -b "/usr/bin" \
+  -d "$PYTHONLIB" \
+  -e "/usr/include/python$PYTHONVER" \
+  CFLAGS="$SLKCFLAGS" \
+  CXXFLAGS="$SLKCFLAGS"
+
+make
+make install DESTDIR=$PKG
+
+(
+  cd $PKG/usr/bin
+  mv sip python3-sip
+)
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog LICENSE* NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-sip/python3-sip.info b/python/python3-sip/python3-sip.info
new file mode 100644 (file)
index 0000000..5715e16
--- /dev/null
@@ -0,0 +1,10 @@
+PRGNAM="python3-sip"
+VERSION="4.18"
+HOMEPAGE="http://www.riverbankcomputing.com/software/sip/intro/"
+DOWNLOAD="https://downloads.sourceforge.net/project/pyqt/sip/sip-4.19.6/sip-4.19.6.tar.gz"
+MD5SUM="6be5cb2c43915ed450a9f74ec110dada"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"
diff --git a/python/python3-sip/slack-desc b/python/python3-sip/slack-desc
new file mode 100644 (file)
index 0000000..4fd2920
--- /dev/null
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+           |-----handy-ruler------------------------------------------------------|
+python3-sip: python3-sip (Tool to generate Python bindings)
+python3-sip:
+python3-sip: SIP is a tool that makes it very easy to create Python bindings for
+python3-sip: C and C++ libraries.  It was originally developed to create PyQt,
+python3-sip: the Python bindings for the Qt toolkit, but can be used to create
+python3-sip: bindings for any C or C++ library.
+python3-sip:
+python3-sip: Homepage: http://www.riverbankcomputing.com/software/sip/intro/
+python3-sip:
+python3-sip:
+python3-sip: